Note: The other languages of the website are Google-translated. Back to English
Einloggen  \/ 
x
or
x
Registrieren  \/ 
x

or

EXCEL COUNTIF-Funktion – Zählen Sie Zellen, die nicht leer, größer/kleiner als oder einen bestimmten Wert enthalten

Wenn Sie an einem Excel-Arbeitsblatt arbeiten, können Sie die Anzahl der Zellen zählen, z. B. leere oder nicht leere Zellen, Zellen, die größer oder kleiner als ein bestimmter Wert sind, oder Zellen, die einen bestimmten Text enthalten, für die meisten Aufgaben häufig uns. Um mit diesen Berechnungen fertig zu werden, kann Ihnen die COUNIT-Funktion in Excel einen Gefallen tun.

Syntax der ZÄHLENWENN-Funktion in Excel

ZÄHLENWENN-Funktion für leere oder nicht leere Zellen

ZÄHLENWENN-Funktion für Zellen kleiner, größer oder gleich einem bestimmten Wert

ZÄHLENWENN-Funktion für Zellen enthält einen bestimmten Wert


Syntax der ZÄHLENWENN-Funktion in Excel

Als eine der statistischen Funktionen in Excel zählt ZÄHLENWENN Zellen, die bestimmte Kriterien in einem angegebenen Bereich erfüllen. Die Syntax der ZÄHLENWENN-Funktion lautet:

=COUNTIF(range, criteria)

Die Syntax enthält zwei Argumente – Angebot . Kriterien:

  • Angebot: bezieht sich auf den Zellbereich, den Sie zählen möchten.
  • Kriterien: bezieht sich auf die Bedingung, die Sie zum Zählen von Zellen verwenden möchten. Sie können beispielsweise „>=80“ als Kriterium verwenden, um im ausgewählten Bereich nach Zellen mit Werten größer oder gleich 80 zu suchen.

Um die Funktion in Excel anzuwenden, sollten Sie eingeben = COUNTIF (Bereich, Kriterien) in einer Zielzelle. Zum Beispiel, =ZÄHLENWENN(A1:B8,">=80").

Die ZÄHLENWENN-Funktion gibt einen numerischen Wert zurück – die Anzahl der Zellen, die Sie zählen möchten.

Da wir nun ein besseres Verständnis der Funktion ZÄHLENWENN haben, gehen wir zu einigen realen Beispielen über.


ZÄHLENWENN-Funktion für leere oder nicht leere Zellen

Ich habe beispielsweise eine Liste von Zellen, die verschiedene Datentypen enthält, wie Text, boolesche Werte (TRUE und FALSE), Zahlen, Datumsangaben und Fehler. Gibt es eine universelle COUNTIF-Formula, um nur leere oder nicht leere Zellen zu zählen, unabhängig davon, welche Datentypen in Ihrem angegebenen Bereich vorhanden sind?

countif leer weniger 1

Zählen Sie leere Zellen mit der ZÄHLENWENN-Funktion

Lassen Sie mich Ihnen nun die ZÄHLENWENN-Formel vorstellen. Mit der Formel, egal wie viele Datentypen im Bereich vorhanden sind, wird Ihnen die genaue und korrekte Anzahl der leeren Zellen mitgeteilt:

=COUNTIF(range,"")
Hinweis: Es gibt keinen Text in Anführungszeichen, was bedeutet, dass die Zellen, die Sie zählen möchten, leer sind.

Um die Funktion ZÄHLENWENN zum Zählen leerer Zellen zu verwenden, geben Sie die Formel ein =ZÄHLENWENN(A1:A9,"") in einer Zielzelle, und drücken Sie dann ENTER:

countif leer weniger 2 >>> countif leer weniger 3

In Excel gibt es auch eine Funktion namens COUNTBLANK, die die Anzahl der leeren Zellen in einem angegebenen Bereich zurückgibt. Die Syntax davon ist = COUNTBLANK (Bereich). Für das obige Beispiel können Sie die Formel verwenden: =ANZAHLLEER(A1:A9).


Zählen Sie nicht leere Zellen mit der ZÄHLENWENN-Funktion

Um die Zellen zu zählen, die nicht leer sind, zeige ich Ihnen hier die Formel:

=COUNTIF(range,"<>")
Hinweis: <> in Excel bedeutet Nicht gleichzusetzen mit. Die obige Formel zählt also alle Zellen, die nicht leer sind, oder wir können sagen, dass sie nicht leer sind.

Um die ZÄHLENWENN-Funktion zu verwenden, um die Zellen zu zählen, die nicht leer sind, geben Sie die Formel ein =ZÄHLENWENN(A1:A9,"<>") in einer Zielzelle, und drücken Sie dann ENTER:

countif leer weniger 4 >>> countif leer weniger 5

In Excel gibt es auch eine Funktion namens Leutnant, die die Anzahl der Zellen zurückgibt, die Werte in einem angegebenen Bereich enthalten. Die Syntax davon ist =ANZAHL(Bereich). Für das obige Beispiel können Sie die Formel verwenden: = COUNTA (A1: A9).

Wenn Sie jedoch nur Zellen mit nur Text zählen und Boolesche Werte (TRUE und FALSE), Zahlen, Datumsangaben oder Fehler ausschließen möchten, verwenden Sie bitte die folgende Formel:

=COUNTIF(A1:A9,"*")
Note: A single asterisk (*) matches only the value in a text form.

countif leer weniger 6 >>> countif leer weniger 7

Zählen Sie nicht leere Zellen mit zwei Klicks

Wenn du have Kutools for Excel in Ihrem Excel installiert, mit seinen Wählen Sie Nicht leere Zellen -Funktion können Sie alle nicht leeren Zellen gleichzeitig auswählen und die gewünschte Zahl abrufen.

1. Sie können zum gehen Kutools Tab in Excel, finde Klicken Sie (sodass dort ein Haken erscheint) auf das RechteckUnd klicken Sie auf Wählen Sie Nicht leere Zellen in der Dropdown-Liste. Siehe Screenshot:

countif leer weniger 8

2. Alle nicht leeren Zellen werden ausgewählt, und eine Eingabeaufforderung wird angezeigt, um Ihnen die Anzahl der nicht leeren Zellen mitzuteilen, wie im folgenden Screenshot gezeigt:

countif leer weniger 9

Klicken Sie hier, um Kutools for Excel für eine 30-tägige kostenlose Testversion herunterzuladen.


ZÄHLENWENN-Funktion für Zellen kleiner, größer oder gleich einem bestimmten Wert

Hier haben wir zwei Hauptmethoden aufgelistet, mit denen Sie Zellen mit Werten zählen können, die kleiner, größer, gleich oder ungleich einem bestimmten Wert in Excel sind.

ZÄHLENWENN kleiner als, größer als, gleich oder ungleich mit Formeln

Um eine Formel zum Zählen von Zellen mit Werten zu verwenden, die kleiner, größer, gleich oder ungleich einem bestimmten Wert sind, sollten Sie Vergleichsoperatoren (<, >, =, ).

Hinweis: Die Methode kann auch zum Zählen von Zellen verwendet werden, deren Datum vor (kleiner als <), nach (größer als >) oder gleich (=) dem von Ihnen angegebenen Datum liegt.

Schauen wir uns nun einige reale Beispiele gemäß der folgenden Tabelle an:

countif leer weniger 10

Um die Anzahl der Schüler zu zählen, deren Gesamtpunktzahl ist über (>) 140, verwenden Sie die Formel:
=ZÄHLENWENN(E2:E8,">140") >>> Das Ergebnis ist 5
Um die Anzahl der Schüler zu zählen, deren mathematische Punktzahl ist niedriger als (<) die Punktzahl von Coco (der Wert in der Zelle D3), verwenden Sie die Formel:
=ZÄHLENWENN(D2:D8,"<"&D3) >>> Das Ergebnis ist 2
Hinweis: Um einen Zellbezug in der ZÄHLENWENN-Funktion mit Vergleichsoperatoren zu verwenden, müssen Sie die Operatoren in Anführungszeichen setzen und ein kaufmännisches Und (&) vor dem Zellbezug hinzufügen.
Um die Anzahl der Schüler zu zählen, deren Englischpunktzahl ist größer oder gleich (≥) die Punktzahl von Eddie (der Wert in der Zelle C4), verwenden Sie die Formel:
=COUNTIF(C2:C8,">="&C4)-1 >>> The result is 5
Hinweis: Der Grund für die Subtraktion von 1 besteht darin, dass die Kriterien C2:C8,">="&C4 Bitten Sie COUNTIF, alle übereinstimmenden Zellen zu zählen, einschließlich der mit Eddies englischen Punktzahl, also müssen wir sie von der Formel subtrahieren. Wenn Sie Eddie mitzählen müssen, löschen Sie „-1“ aus der Formel.
Um die Anzahl der Schüler zu zählen, die sind von (=) Indien, verwenden Sie die Formel:
=ZÄHLENWENN(B2:B8,"Indien") OR =ZÄHLENWENN(B2:B8,B2) >>> Das Ergebnis ist 3
Hinweis: Der Wert in der Zellreferenz B2 ist Indien, also "Indien" . B2 sind beide in Ordnung, hier als Kriterien zu arbeiten. In der Funktion ZÄHLENWENN sind die Kriterien Groß-/Kleinschreibung nicht beachten. Die Zeichenfolgen „India“ und „INDIA“ haben also keinen Einfluss auf das Ergebnis der Formel.
Um die Anzahl der Schüler zu zählen, die sind nicht aus (≠) Indien, verwende die Formel:
=ZÄHLENWENN(B2:B8,"<>Indien") OR =ZÄHLENWENN(B2:B8,"<>"&B2) >>> Das Ergebnis ist 4

Die ZÄHLENWENN-Funktion funktioniert nur, wenn eine Bedingung vorliegt, bei mehreren Bedingungen sollten Sie die ZÄHLENWENN-Funktion verwenden. Um beispielsweise die Anzahl der Schüler zu zählen, deren Englischpunktzahl zwischen 60 und 90 (>60, <90) liegt, verwenden Sie die Formel: =COUNTIFS(B2:B8,">60",B2:B8,"<90").
Klicken Sie hier, um mehr über die ZÄHLENWENN-Funktion zu erfahren…


ZÄHLENWENN kleiner als, größer als, gleich oder ungleich mit wenigen Klicks

Um Zellen mit Werten, die kleiner, größer, gleich oder ungleich einem bestimmten Wert sind, auf bequemere Weise zu zählen, können Sie die Wählen Sie Bestimmte Zellen aus Funktion ausf Kutools for Excel.

Führen Sie nach der Installation von Kutools for Excel die folgenden Schritte aus:

1. Bitte finden Sie die Kutools Tab, dann gehe zu Klicken Sie (sodass dort ein Haken erscheint) auf das RechteckUnd klicken Sie auf Wählen Sie Bestimmte Zellen aus in der Dropdown-Liste.

countif leer weniger 11

2. Nun sehen Sie ein Popup-Fenster, gehen Sie bitte wie folgt vor:

countif leer weniger 11

Unten ist ein Beispiel, um die Anzahl der Schüler zu zählen, deren mathematische Punktzahl ist niedriger als (<) die Partitur von Coco mit Kutools.

countif leer weniger 11

Hinweis: Das Programm gibt das Zählergebnis zurück und wählt die Zelle(n) aus, die Ihren Kriterien entsprechen. Sie können sie bei Bedarf kopieren.

Klicken Sie hier, um Kutools for Excel für eine 30-tägige kostenlose Testversion herunterzuladen.


ZÄHLENWENN-Funktion für Zellen enthält einen bestimmten Wert

Um ZÄHLENWENN zu verwenden, um die Zellen zu zählen, die einen bestimmten Wert enthalten (z. B. die Zellen mit dem Buchstaben Y), oder sogar die Zellen mit einem bestimmten Wert an einer bestimmten Position zu zählen (z müssen die Platzhalterzeichen kennen.

Es gibt drei Platzhalterzeichen - Sternchen (*), Frage Kennzeichen (?), Und Tilde (~) in Excel für die ZÄHLENWENN-Funktion verfügbar:

Sternchen (*) - Entspricht einer beliebigen Anzahl von Zeichen. Zum Beispiel könnte *ice nett, service, ice, @#$ice usw. bedeuten.
Fragezeichen (?) - Entspricht einem beliebigen Zeichen. Zum Beispiel, mo?? könnte mehr bedeuten, moon, mo&%, moaa usw.
Tilde (~) - Entspricht dem tatsächlichen Platzhalterzeichen. Zum Beispiel bedeutet ~* ein literales Sternchen, ~~ bedeutet eine wörtliche Tilde.

Hinweis: Boolesche Werte (TRUE und FALSE), Zahlen, Datumsangaben und Fehler werden nicht als Zeichen gezählt. Wenn sich also im ausgewählten Zellbereich obige Elemente befinden, müssen Sie sie in Text umwandeln.

Weitere Informationen:
Wie man Zahl in Text in Excel ändert oder umwandelt?
Wie konvertiert man Datum in Zahlenzeichenfolge oder Textformat in Excel?
Wie ersetzt man # Formelfehler durch 0, leeren oder bestimmten Text in Excel?
Wie konvertiert man Boolean True/False in Zahl (1/0) oder Text in Excel?


Zählen Sie Zellen mit bestimmten Wörtern oder Zeichen mit der ZÄHLENWENN-Funktion

Da wir die Platzhalterzeichen bereits kennen, ist es an der Zeit, zu lernen, wie man eine ZÄHLENWENN-Formel verwendet, um die Zellen zu zählen, die ein oder mehrere bestimmte Zeichen oder Wörter enthalten. Sehen wir uns die Beispiele unten an:

countif leer weniger 1

Um die Anzahl der Jungen in der Klasse zu zählen, verwenden Sie die Formel:
=ZÄHLENWENN(B2:B9,"MALE") >>> Das Ergebnis ist 5
Um die Anzahl der Namen zu zählen, die die Zeichen „jeff“ (den Wert in Zelle A6) enthalten, verwenden Sie die Formel:
=ZÄHLENWENN(A2:A9,"*jeff*") OR = COUNTIF (A2: A9, "*" & A6 & "*") >>> Das Ergebnis ist 2
Um die Anzahl der Namen zu zählen, die den Buchstaben „e“ enthalten, verwenden Sie die Formel:
=COUNTIF(A2:A9,"*e*") >>> The result is 5
Um die Anzahl der Namen zu zählen, die den Buchstaben „e“ nicht enthalten, verwenden Sie die Formel:
=ZÄHLENWENN(A2:A9,"<>*e*") >>> Das Ergebnis ist 3
Um die Anzahl der Namen zu zählen, die mit dem Buchstaben „e“ beginnen, verwenden Sie die Formel:
=ZÄHLENWENN(A2:A9,"e*") >>> Das Ergebnis ist 2
Um die Anzahl der Namen zu zählen, die mit dem Buchstaben „e“ enden, verwenden Sie die Formel:
=ZÄHLENWENN(A2:A9,"*e") >>> Das Ergebnis ist 1
Um die Anzahl der Namen mit dem Buchstaben „m“ als drittem Zeichen zu zählen, verwenden Sie die Formel:
=ZÄHLENWENN(A2:A9,"??m*") >>> Das Ergebnis ist 2

Zählen Sie Zellen mit bestimmten Wörtern oder Zeichen mit wenigen Klicks

Mit our Excel-Add-In instAlles in allem gehen Sie bitte wie folgt vor:

1. Gehen Sie zum Kutools Registerkarte finden Klicken Sie (sodass dort ein Haken erscheint) auf das RechteckUnd klicken Sie auf Wählen Sie Bestimmte Zellen aus in der Dropdown-Liste.

countif leer weniger 1

2. In dem Wählen Sie Bestimmte Zellen aus Wählen Sie im Dialogfeld den Zellbereich aus, den Sie zählen möchten, und klicken Sie dann auf Zelle unter dem Auswahltyp, wählen Sie eine Bedingung in der Dropdown-Liste der Spezifischer Typ nach Ihren Bedürfnissen.

countif leer weniger 1

Hier gebe ich Ihnen zwei Beispiele des Verwendens Kutools zu beratent die Zellen, die die spezifischen Wörter oder Zeichen enthalten.

• Um die Anzahl der Jungen in der Klasse zu zählen, klicken Sie auf Equals in der Dropdown-Liste und geben Sie Männlich im rechten Eingabefeld, oder Sie wählen eine Zelle mit dem Wert „Männlich“ im Arbeitsblatt aus, indem Sie auf klicken countif leer weniger 1.

countif leer weniger 1

Das Programm gibt das Zählergebnis zurück und wählt die Zelle(n) aus, die Ihren Kriterien entsprechen. Sie können sie bei Bedarf kopieren.

• Um die Anzahl der Namen zu zählen, die die Zeichen „jeff“ enthalten, klicken Sie auf Enthält in der Dropdown-Liste und geben Sie jeff, oder Sie können die Zelle A6 im Arbeitsblatt auswählen, indem Sie auf klicken countif leer weniger 1.

countif leer weniger 1

Das Programm gibt das Zählergebnis zurück und wählt die Zelle(n) aus, die Ihren Kriterien entsprechen. Sie können sie bei Bedarf kopieren.



  • Super Formula Bar (leicht mehrere Textzeilen und Formeln bearbeiten); Layout lesen (leichtes Lesen und Bearbeiten einer großen Anzahl von Zellen); In gefilterten Bereich einfügen...
  • Zellen / Zeilen / Spalten zusammenführen und Speichern von Daten; Inhalt geteilter Zellen; Kombinieren Sie doppelte Zeilen und Summe / Durchschnitt... doppelte Zellen verhindern; Bereiche vergleichen...
  • Wählen Sie Duplizieren oder Eindeutig Reihen; Wählen Sie Leere Zeilen (alle Zellen sind leer); Super Find und Fuzzy Find in vielen Arbeitsmappen; Zufällige Auswahl ...
  • Exakte Kopie Mehrere Zellen ohne Änderung der Formelreferenz; Referenzen automatisch erstellen zu mehreren Blättern; Aufzählungszeichen einfügen, Kontrollkästchen und mehr ...
  • Lieblingsformeln und schnell einfügen, Bereiche, Diagramme und Bilder; Zellen verschlüsseln mit Passwort; Mailingliste erstellen und E-Mails senden ...
  • Text extrahieren, Text hinzufügen, Nach Position entfernen, Leerzeichen entfernen;; Paging-Zwischensummen erstellen und drucken; Inhalt und Kommentare zwischen Zellen konvertieren...
  • Superfilter (Speichern und Anwenden von Filterschemata auf andere Blätter); Erweiterte Sortierung nach Monat / Woche / Tag, Häufigkeit und mehr; Spezialfilter fett, kursiv ...
  • Kombinieren Sie Arbeitsmappen und Arbeitsblätter;; Tabellen basierend auf Schlüsselspalten zusammenführen; Daten in mehrere Blätter aufteilen; Batch-Konvertierung von xls, xlsx und PDF...
  • Pivot-Tabellengruppierung nach Wochennummer, Wochentag und mehr ... Entsperrte, gesperrte Zellen anzeigen durch verschiedene Farben; Markieren Sie Zellen mit Formel / Name...
kte tab 201905
  • Aktivieren Sie das Bearbeiten und Lesen von Registerkarten in Word, Excel und PowerPoint, Publisher, Access, Visio und Project.
  • Öffnen und erstellen Sie mehrere Dokumente in neuen Registerkarten desselben Fensters und nicht in neuen Fenstern.
  • Erhöht Ihre Produktivität um 50 % und reduziert jeden Tag Hunderte von Mausklicks für Sie!
officetab unten
Say something here...
symbols left.
You are guest
or post as a guest, but your post won't be published automatically.
Loading comment... The comment will be refreshed after 00:00.

Be the first to comment.