Note: The other languages of the website are Google-translated. Back to English

Lokalisiere den ersten Fehler

Um die Position des ersten Fehlers in einer Spalte oder Zeile zu finden, die PASSEN ZU und ISERROR-Funktionen können Ihnen einen Gefallen tun.

Suchen Sie den ersten Fehler 1

Wie gleicht man den ersten Fehler in einer Spalte oder Zeile ab?

Für die Position des ersten Fehlers in der Liste wie oben gezeigt, können Sie zuerst die ISERROR-Funktion verwenden, um jeden Wert in der Liste zu überprüfen, ob es sich um Fehler handelt oder nicht. Die Funktion generiert dann ein TRUE- und FALSE-Array, in dem TRUE einen Wert darstellt, der ein Fehler ist, andernfalls FALSE. Die MATCH-Funktion gleicht dann das erste TURE im Array ab, um die Position des ersten Fehlers in einem numerischen Wert zurückzugeben.

Generische Syntax

=MATCH(TRUE,ISERROR(range),0)

√ Hinweis: Dies ist eine Matrixformel, die Sie mit eingeben müssen Ctrl + Verschiebung + Weiter.

  • Angebot: Der einspaltige oder einzeilige Bereich, aus dem der erste Fehler zurückgegeben werden soll.
  • 0: Das Übereinstimmungstyp 0 zwingt MATCH, eine exakte Übereinstimmung durchzuführen.

Passend zum Position des ersten Fehlers, bitte kopieren oder geben Sie die Formel unten in die Zelle D5 ein und drücken Sie Ctrl + Verschiebung + Weiter um das Ergebnis zu erhalten:

=VERGLEICH(WAHR,FEHLER(B5: B14),0)

Suchen Sie den ersten Fehler 2

Erklärung der Formel

=MATCH(TRUE,ISERROR(B5:B14),0)

  • FEHLER (B5:B14): Die ISERROR-Funktion überprüft jeden Wert im Bereich B5:B14, ob es sich um Fehler handelt oder nicht, und gibt ein TRUE zurück, wenn ein Wert ein Fehler ist, andernfalls ein FALSE. Die Ergebnisse wären in einem Array wie diesem: {FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;WAHR;FALSCH;FALSCH}.
  • ÜBEREINSTIMMUNG(WAHR,FEHLER (B5:B14),0) = ÜBEREINSTIMMUNG(WAHR,{FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;FALSCH;WAHR;FALSCH;FALSCH},0): Das Übereinstimmungstyp 0 zwingt die MATCH-Funktion, eine exakte Übereinstimmung durchzuführen. Die Funktion gibt dann die Position des ersten exakten TRUE im Array zurück. Die Funktion kehrt also zurück 8 da das erste WAHR am ist 8th Position.

Gut zu wissen

  • Um den Fehlerwert an der von MATCH bereitgestellten Position abzurufen, können Sie Fügen Sie die INDEX-Funktion hinzu.
  • Die ISERROR-Funktion in der obigen Formel gleicht alle Fehler ab. Wenn Sie nur mit dem ersten übereinstimmen möchten #N / A Fehler, bitte ändern Sie den ISERROR in ISNA:
    =VERGLEICH(WAHR,ISNA(Angebot),0)

Verwandte Funktionen

Excel MATCH-Funktion

Die Excel MATCH-Funktion sucht in einem Zellbereich nach einem bestimmten Wert und gibt die relative Position des Werts zurück.


Verwandte Formeln

Suchen Sie die erste teilweise Übereinstimmung mit Platzhaltern

Um die Position der ersten teilweisen Übereinstimmung zu ermitteln, die eine bestimmte Textzeichenfolge in einem Bereich in Excel enthält, können Sie eine MATCH-Formel mit Platzhalterzeichen verwenden – dem Sternchen (*) und dem Fragezeichen (?).

Suchen Sie das erste Match, das nicht mit beginnt

Um die Position des ersten Treffers zu finden, der nicht mit einer bestimmten Zeichenfolge beginnt, können Ihnen die Funktionen MATCH, LEFT und IF einen Gefallen tun.

Suchen Sie die erste Übereinstimmung, die nicht enthält

Um die Position des ersten Treffers zu finden, der eine bestimmte Zeichenfolge nicht enthält, können Sie eine Formel verwenden, die auf den Funktionen MATCH, ISNUMBER und SEARCH basiert.

Maximalwert in einem Bereich lokalisieren

Es gibt Fälle, in denen Sie die Position des Maximalwerts in einer Liste, Tabelle oder Zeile in Excel ermitteln müssen. In diesem Tutorial besprechen wir den Ansatz, um die Aufgabe mit den Funktionen MAX und MATCH zu lösen.


Die besten Tools für die Office-Produktivität

Kutools für Excel - Hilft Ihnen, sich von der Masse abzuheben

Sie möchten Ihre tägliche Arbeit schnell und perfekt erledigen? Kutools for Excel bietet 300 leistungsstarke erweiterte Funktionen (Arbeitsmappen kombinieren, nach Farbe summieren, Zelleninhalte teilen, Datum konvertieren usw.) und 80% Zeit für Sie sparen.

  • Entwickelt für 1500 Arbeitsszenarien, hilft Ihnen, 80 % der Excel-Probleme zu lösen.
  • Reduzieren Sie täglich Tausende von Tastatur- und Mausklicks und entlasten Sie Ihre müden Augen und Hände.
  • Werden Sie in 3 Minuten ein Excel-Experte. Sie müssen sich keine schmerzhaften Formeln und VBA-Codes mehr merken.
  • 30 Tage unbegrenzte kostenlose Testversion. 60 Tage Geld-zurück-Garantie. Kostenloses Upgrade und Support für 2 Jahre.
Excel-Multifunktionsleiste (mit installiertem Kutools für Excel)

Office-Registerkarte - Aktivieren Sie das Lesen und Bearbeiten von Registerkarten in Microsoft Office (einschließlich Excel).

  • Eine Sekunde, um zwischen Dutzenden offener Dokumente zu wechseln!
  • Reduzieren Sie jeden Tag Hunderte von Mausklicks für Sie und verabschieden Sie sich von der Maushand.
  • Erhöht Ihre Produktivität um 50 % beim Anzeigen und Bearbeiten mehrerer Dokumente.
  • Bringt effiziente Registerkarten in Office (einschließlich Excel), genau wie Chrome, Firefox und New Internet Explorer.
Screenshot von Excel (mit installiertem Office Tab)
Kommentare (0)
Noch keine Bewertungen. Bewerten Sie als Erster!
Es sind noch keine Kommentare vorhanden
Hinterlassen Sie Ihre Kommentare
Als Gast posten
×
Bewerte diese Nachricht:
0   Figuren
Vorgeschlagene Standorte

Folgen Sie uns

Copyright © 2009 - www.extendoffice.com. | Alle Rechte vorbehalten. Unterstützt von ExtendOffice. | Sitemap
Microsoft und das Office-Logo sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und / oder anderen Ländern.
Geschützt durch Sectigo SSL