Note: The other languages of the website are Google-translated. Back to English

Suchen Sie die erste Übereinstimmung, die nicht enthält

Um die Position des ersten Treffers zu finden, der eine bestimmte Zeichenfolge nicht enthält, können Sie eine Formel verwenden, die auf dem basiert PASSEN ZU, ISNUMMER und SUCHE Funktionen.

Suchen Sie die erste Übereinstimmung, die keine 1 enthält

Wie finde ich die erste Übereinstimmung, die die Zeichenfolge „TOOL“ nicht enthält?

Für die Position des ersten Werts, der die Zeichenkette „TOOL“ nicht enthält In der obigen Liste können Sie die Funktionen SEARCH und ISNUMBER verwenden, um ein TRUE- und FALSE-Array zu generieren, in dem TRUE einen Wert darstellt, der die Zeichenfolge „TOOL“ enthält, und FALSE einen Wert darstellt, der die Zeichenfolge nicht enthält. Die MATCH-Funktion gleicht dann das erste FALSE im Array ab, um die Position des ersten Werts zurückzugeben, der die Zeichenfolge „TOOL“ nicht enthält.

Generische Syntax

=MATCH(FALSE,ISNUMBER(SEARCH(lookup_value,range)),0)

√ Hinweis: Dies ist eine Matrixformel, die Sie mit eingeben müssen Ctrl + Verschiebung + Weiter.

  • Lookup-Wert: Die Zeichenfolge, die Sie angegeben haben, um mit dem ersten Wert übereinzustimmen, der sie nicht enthält. Die Zeichenfolge sollte in doppelte Anführungszeichen eingeschlossen werden, da sonst das Ergebnis falsch wird. Oder Sie können einen Zellbezug verwenden, um doppelte Anführungszeichen zu vermeiden.
  • Angebot: Die Liste, aus der der erste Wert zurückgegeben werden soll, der das nicht enthält Lookup-Wert.
  • 0: Das Übereinstimmungstyp 0 zwingt MATCH, eine exakte Übereinstimmung durchzuführen.

Für die Position des ersten Werts, der die Zeichenkette „TOOL“ nicht enthält, bitte kopieren oder geben Sie die Formel unten in die Zelle E5 ein und drücken Sie Ctrl + Verschiebung + Weiter um das Ergebnis zu erhalten:

=VERGLEICH(FALSCH,ISZAHL(SUCHE("WERKZEUG",B5: B11)),0)

Oder verwenden Sie einen Zellbezug, um die Formel dynamisch zu machen:

=VERGLEICH(FALSCH,ISZAHL(SUCHE(E4,B5: B11)),0)

Suchen Sie die erste Übereinstimmung, die keine 2 enthält

Erklärung der Formel

=MATCH(FALSE,(ISNUMBER(SEARCH(E4,B5:B11)),0)

  • SUCHE(E4,B5:B11): Die SEARCH-Funktion sucht nach der Zeichenfolge TOOL (Wert in E4) in jedem Wert im Bereich B5: B11, und gibt die Nummern der Anfangsposition der Zeichenfolge in diesen Werten in einem Array zurück: {3;3;4;#VALUE!;1;3;#VALUE!}.
  • IST NUMMER(SUCHE(E4,B5:B11)) = IST NUMMER({3;3;4;#VALUE!;1;3;#VALUE!}): ISNUMBER setzt die Zahlen im Array auf WAHR und andere Werte auf FALSCH. Das Ergebnis wird also so aussehen: {WAHR;WAHR;WAHR;FALSCH;WAHR;WAHR;FALSCH}.
  • ÜBEREINSTIMMUNG(FALSCH,(IST NUMMER(SUCHE(E4,B5:B11)),0) = ÜBEREINSTIMMUNG(FALSCH,({WAHR;WAHR;WAHR;FALSCH;WAHR;WAHR;FALSCH},0): Das Übereinstimmungstyp 0 zwingt die MATCH-Funktion, eine exakte Übereinstimmung durchzuführen. Die Funktion gibt dann die Position des ersten exakten FALSE im Array zurück. Die Funktion kehrt also zurück 4 da steht das erste FALSE an der 4th Position.

Gut zu wissen


Verwandte Funktionen

Excel MATCH-Funktion

Die Excel MATCH-Funktion sucht in einem Zellbereich nach einem bestimmten Wert und gibt die relative Position des Werts zurück.

Excel-Suchfunktion

In Excel kann Ihnen die SEARCH-Funktion dabei helfen, die Position eines bestimmten Zeichens oder Teilstrings aus der angegebenen Textzeichenfolge zu ermitteln, wie im folgenden Screenshot gezeigt. In diesem Tutorial werde ich die Verwendung dieser SEARCH-Funktion in Excel vorstellen.


Verwandte Formeln

Suchen Sie die erste teilweise Übereinstimmung mit Platzhaltern

Um die Position der ersten teilweisen Übereinstimmung zu ermitteln, die eine bestimmte Textzeichenfolge in einem Bereich in Excel enthält, können Sie eine MATCH-Formel mit Platzhalterzeichen verwenden – dem Sternchen (*) und dem Fragezeichen (?).

Suchen Sie das erste Match, das nicht mit beginnt

Um die Position des ersten Treffers zu finden, der nicht mit einer bestimmten Zeichenfolge beginnt, können Ihnen die Funktionen MATCH, LEFT und IF einen Gefallen tun.

Lokalisiere den ersten Fehler

Um die Position des ersten Fehlers in einer Spalte oder Zeile zu finden, können Ihnen die Funktionen MATCH und ISERROR einen Gefallen tun.

Maximalwert in einem Bereich lokalisieren

Es gibt Fälle, in denen Sie die Position des Maximalwerts in einer Liste, Tabelle oder Zeile in Excel ermitteln müssen. In diesem Tutorial besprechen wir den Ansatz, um die Aufgabe mit den Funktionen MAX und MATCH zu lösen.


Die besten Tools für die Office-Produktivität

Kutools für Excel - Hilft Ihnen, sich von der Masse abzuheben

Sie möchten Ihre tägliche Arbeit schnell und perfekt erledigen? Kutools for Excel bietet 300 leistungsstarke erweiterte Funktionen (Arbeitsmappen kombinieren, nach Farbe summieren, Zelleninhalte teilen, Datum konvertieren usw.) und 80% Zeit für Sie sparen.

  • Entwickelt für 1500 Arbeitsszenarien, hilft Ihnen, 80 % der Excel-Probleme zu lösen.
  • Reduzieren Sie täglich Tausende von Tastatur- und Mausklicks und entlasten Sie Ihre müden Augen und Hände.
  • Werden Sie in 3 Minuten ein Excel-Experte. Sie müssen sich keine schmerzhaften Formeln und VBA-Codes mehr merken.
  • 30 Tage unbegrenzte kostenlose Testversion. 60 Tage Geld-zurück-Garantie. Kostenloses Upgrade und Support für 2 Jahre.
Excel-Multifunktionsleiste (mit installiertem Kutools für Excel)

Office-Registerkarte - Aktivieren Sie das Lesen und Bearbeiten von Registerkarten in Microsoft Office (einschließlich Excel).

  • Eine Sekunde, um zwischen Dutzenden offener Dokumente zu wechseln!
  • Reduzieren Sie jeden Tag Hunderte von Mausklicks für Sie und verabschieden Sie sich von der Maushand.
  • Erhöht Ihre Produktivität um 50 % beim Anzeigen und Bearbeiten mehrerer Dokumente.
  • Bringt effiziente Registerkarten in Office (einschließlich Excel), genau wie Chrome, Firefox und New Internet Explorer.
Screenshot von Excel (mit installiertem Office Tab)
Kommentare (0)
Noch keine Bewertungen. Bewerten Sie als Erster!
Es sind noch keine Kommentare vorhanden
Hinterlassen Sie Ihre Kommentare
Als Gast posten
×
Bewerte diese Nachricht:
0   Figuren
Vorgeschlagene Standorte

Folgen Sie uns

Copyright © 2009 - www.extendoffice.com. | Alle Rechte vorbehalten. Unterstützt von ExtendOffice. | Sitemap
Microsoft und das Office-Logo sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und / oder anderen Ländern.
Geschützt durch Sectigo SSL