Note: The other languages of the website are Google-translated. Back to English

Summe der kleinsten oder niedrigsten N-Werte in Excel

In Excel ist es einfach, einen Zellbereich mit der SUM-Funktion zu summieren. Manchmal müssen Sie möglicherweise die kleinsten oder niedrigsten 3, 5 oder n Zahlen in einem Datenbereich summieren, wie unten im Screenshot gezeigt. In diesem Fall kann Ihnen das SUMMENPRODUKT zusammen mit der Funktion SMALL helfen, dieses Problem in Excel zu lösen.


Summieren Sie die kleinsten oder niedrigsten N-Werte mit den Funktionen SUMPRODUCT und SMALL

Um die kleinste n Zahl in einem Datenbereich zu summieren, können Sie die kleinsten n Zahlen mit der Funktion SMALL finden und dann die Funktion SUMPRODUCT anwenden, um die Arrayliste direkt zu summieren. Die generische Syntax lautet:

=SUMPRODUCT(SMALL(range,{1,2,…,N}))
  • range: Der Zellbereich enthält die zu summierenden Zahlen;
  • N: Repräsentiert den N-ten unteren Wert.

Hier summiere ich die niedrigsten 4 Zahlen im Bereich B2: B12, bitte geben Sie die folgende Formel ein oder kopieren Sie sie in eine leere Zelle und drücken Sie Weiter Schlüssel, um das Ergebnis zu erhalten:

=SUMPRODUCT(SMALL(B2:B12,{1,2,3,4}))


Erklärung der Formel:

=SUMMENPRODUKT(KLEIN(B2:B12,{1,2,3,4}))

  • KLEIN(B2:B12,{1,2,3,4}):Diese SMALL-Funktion wird verwendet, um die 1., 2., 3. und 4. kleinsten Werte im Bereich B2:B12 zurückzugeben. Sie erhalten das Array wie folgt: {200,230,345,560}.
  • SUMMENPRODUKT(KLEIN(B2:B12,{1,2,3,4}))=SUMMENPRODUKT({200,230,345,560}): Die SUMPRODUCT-Funktion summiert alle Zahlen in der Array-Liste, um das Ergebnis zu erhalten: 1335.

Tipps: Lösung, wenn N groß wird:

Manchmal haben Sie möglicherweise eine große Liste von Zahlen, um die kleinsten 50 oder mehr Zahlen im Bereich zu summieren, ist es mühsam, die Zahl 1,2,3,4…50 in die Funktion KLEIN einzugeben. Hier können Sie also die Funktionen ROW und INDIRECT verwenden, um die Array-Konstante zu erstellen.

Um beispielsweise die niedrigsten 10 Werte in einem Bereich zu summieren, wenden Sie bitte die folgenden Formeln an:

Manuelle Eingabe einer Zahl:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:10"))))

Verwenden Sie einen Zellbezug:

=SUMPRODUCT(SMALL(B2:B15,ROW(INDIRECT("1:"&D2))))


Verwendete relative Funktion:

  • SUMMENPRODUKT:
  • Die SUMPRODUCT-Funktion kann verwendet werden, um zwei oder mehr Spalten oder Arrays miteinander zu multiplizieren und dann die Summe der Produkte zu erhalten.
  • SMALL:
  • Die Excel-Funktion SMALL gibt einen numerischen Wert basierend auf seiner Position in einer Liste zurück, wenn er nach Wert in aufsteigender Reihenfolge sortiert wird.

Weitere Artikel:

  • Summe der kleinsten oder niedrigsten N-Werte basierend auf Kriterien
  • Im vorherigen Tutorial haben wir besprochen, wie die kleinsten n-Werte in einem Datenbereich summiert werden. In diesem Artikel werden wir eine weitere erweiterte Operation durchführen – um die niedrigsten n-Werte basierend auf einem oder mehreren Kriterien in Excel zu summieren.
  • Zwischensumme der Rechnungsbeträge nach Alter in Excel
  • Das Summieren der Rechnungsbeträge basierend auf dem Alter, wie unten im Screenshot gezeigt, kann eine häufige Aufgabe in Excel sein. Dieses Tutorial zeigt, wie Sie mit einer normalen SUMIF-Funktion Rechnungsbeträge nach Alter subsumieren.
  • Alle Zahlenzellen summieren, Fehler ignorieren
  • Beim Summieren eines Zahlenbereichs, der einige Fehlerwerte enthält, funktioniert die normale SUM-Funktion nicht richtig. Um nur Zahlen zu summieren und die Fehlerwerte zu überspringen, können Ihnen die AGGREGATE-Funktion oder die SUMME zusammen mit den IFERROR-Funktionen einen Gefallen tun.

Die besten Tools für die Office-Produktivität

Kutools für Excel - Hilft Ihnen, sich von der Masse abzuheben

Sie möchten Ihre tägliche Arbeit schnell und perfekt erledigen? Kutools for Excel bietet 300 leistungsstarke erweiterte Funktionen (Arbeitsmappen kombinieren, nach Farbe summieren, Zelleninhalte teilen, Datum konvertieren usw.) und 80% Zeit für Sie sparen.

  • Entwickelt für 1500 Arbeitsszenarien, hilft Ihnen, 80 % der Excel-Probleme zu lösen.
  • Reduzieren Sie täglich Tausende von Tastatur- und Mausklicks und entlasten Sie Ihre müden Augen und Hände.
  • Werden Sie in 3 Minuten ein Excel-Experte. Sie müssen sich keine schmerzhaften Formeln und VBA-Codes mehr merken.
  • 30 Tage unbegrenzte kostenlose Testversion. 60 Tage Geld-zurück-Garantie. Kostenloses Upgrade und Support für 2 Jahre.
Excel-Multifunktionsleiste (mit installiertem Kutools für Excel)

Office-Registerkarte - Aktivieren Sie das Lesen und Bearbeiten von Registerkarten in Microsoft Office (einschließlich Excel).

  • Eine Sekunde, um zwischen Dutzenden offener Dokumente zu wechseln!
  • Reduzieren Sie jeden Tag Hunderte von Mausklicks für Sie und verabschieden Sie sich von der Maushand.
  • Erhöht Ihre Produktivität um 50 % beim Anzeigen und Bearbeiten mehrerer Dokumente.
  • Bringt effiziente Registerkarten in Office (einschließlich Excel), genau wie Chrome, Firefox und New Internet Explorer.
Screenshot von Excel (mit installiertem Office Tab)
Kommentare (0)
Noch keine Bewertungen. Bewerten Sie als Erster!
Es sind noch keine Kommentare vorhanden
Hinterlassen Sie Ihre Kommentare
Als Gast posten
×
Bewerte diese Nachricht:
0   Figuren
Vorgeschlagene Standorte

Folgen Sie uns

Copyright © 2009 - www.extendoffice.com. | Alle Rechte vorbehalten. Unterstützt von ExtendOffice. | Sitemap
Microsoft und das Office-Logo sind Marken oder eingetragene Marken der Microsoft Corporation in den USA und / oder anderen Ländern.
Geschützt durch Sectigo SSL